They're here! More Muvipix.com Guides by Steve Grisetti!
The Muvipix.com Guides to Premiere & Photoshop Elements 2019
Not quite sure what our site has to offer?
Check out the
Muvipix Video Tour

Has Google gone mad?

Talk about computer software/hardware problems, related to digital video or otherwise.

Has Google gone mad?

Postby BuddyB » Thu Jun 06, 2019 9:52 am

Or am I losing it? As far as I'm concerned the new procedure sucks! When searching and click on a search file all I get is more search files..and it goes on and one. If I'm fortunate, and it's getting rarer, I have to scroll way down and maybe I'll find a file I'm looking for; that's a maybe. And of course you have all those grubbing apps at the top that require a download of their app before you can do anything. Wow, do I miss the original search procedure. Any suggestions for a better Search Engine? Thanks, and maybe I'm all coo coo over this.
"Wichitaito-Everything is Everything"
ASUS M4A88T-M mb-AthlonII X 3 455 1.5 Cache-8GB DDR3-1600-PC3-12800(2X4GB Dual Channel)-1TB SATA3 6gb/sec 7200rpm(64MB Cache) Win10 64Bit-Sony Movie Studio Suite 13-XaraX photo/Art/Web Adobe Cloud.
User avatar
BuddyB
Super Contributor
Super Contributor
 
Posts: 877
Joined: Wed Feb 27, 2013 1:44 pm

Re: Has Google gone mad?

Postby Peru » Thu Jun 06, 2019 10:50 am

I'm not experiencing any problems with Google Search.
Are you using Chrome? If so, what version?
Can you post a screenshot about the issue?
User avatar
Peru
Moderator
Moderator
 
Posts: 3269
Joined: Wed Oct 17, 2007 12:34 pm
Location: Peru, NY, USA

Re: Has Google gone mad?

Postby Dave McElderry » Thu Jun 06, 2019 10:55 am

Sounds like you've got a browser hijacker. They'll redirect you to the type of stuff you describe. Check your browser extensions for anything that doesn't belong there and get rid of it.
Be yourself; everyone else is taken.

Studio XPS 435T, 2.93 GHz i7-940; Win 10-64; 24GB RAM; Samsung 512GB SSD (OS); two 1TB HDDs; GeForce GTX 550 Ti 1GB
User avatar
Dave McElderry
Moderator
Moderator
 
Posts: 4107
Joined: Fri Feb 23, 2007 10:18 am
Location: Lost In Middle America

Re: Has Google gone mad?

Postby BuddyB » Thu Jun 06, 2019 11:04 am

Peru I have been using Firefox for years, no problem until recently. Thanks Dave, didn't think to check that out; will do.
"Wichitaito-Everything is Everything"
ASUS M4A88T-M mb-AthlonII X 3 455 1.5 Cache-8GB DDR3-1600-PC3-12800(2X4GB Dual Channel)-1TB SATA3 6gb/sec 7200rpm(64MB Cache) Win10 64Bit-Sony Movie Studio Suite 13-XaraX photo/Art/Web Adobe Cloud.
User avatar
BuddyB
Super Contributor
Super Contributor
 
Posts: 877
Joined: Wed Feb 27, 2013 1:44 pm

Re: Has Google gone mad?

Postby Chuck Engels » Fri Jun 07, 2019 1:26 pm

Yup, I agree with Dave. Check your default search engine and make sure it is the real Google :)
1. Thinkpad W530 Laptop, Core i7-3820QM Processor 8M Cache 3.70 GHz, 16 GB DDR3, NVIDIA Quadro K1000M 2GB Memory.

2. Cybertron PC - Liquid Cooled AMD FX6300, 6 cores, 3.50ghz - 32GB DDR3 - MSI GeForce GTX 960 Gaming 4G, 4GB Video Ram, 1024 Cuda Cores.
User avatar
Chuck Engels
Super Moderator
Super Moderator
 
Posts: 17641
Joined: Sun Feb 11, 2007 10:58 pm
Location: Atlanta, GA

Re: Has Google gone mad?

Postby BuddyB » Fri Jun 07, 2019 1:27 pm

Thanks chuck
"Wichitaito-Everything is Everything"
ASUS M4A88T-M mb-AthlonII X 3 455 1.5 Cache-8GB DDR3-1600-PC3-12800(2X4GB Dual Channel)-1TB SATA3 6gb/sec 7200rpm(64MB Cache) Win10 64Bit-Sony Movie Studio Suite 13-XaraX photo/Art/Web Adobe Cloud.
User avatar
BuddyB
Super Contributor
Super Contributor
 
Posts: 877
Joined: Wed Feb 27, 2013 1:44 pm


Return to Computer Issues 


Similar topics


Who is online

Users browsing this forum: Google [Bot] and 1 guest